please I need assistance with this error.

My MySQL stopped working and each time I start MYSQL on the XAMPP Control Panel, it initiates an error as shown on the screenshot below.

I just reinstalled the latest XAMPP on my windows 10 PC. I used it for a few hours before it crashed.

I have tried restarting the PC and nothing changed. I would be grateful to get any relevant solution.


enter image description here

The Error Log

2019-03-14 10:26:28 2da0 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2019-03-14 10:26:28 11680 [Note] InnoDB: innodb_empty_free_list_algorithm has been changed to legacy because of small buffer pool size. In order to use backoff, increase buffer pool at least up to 20MB.

2019-03-14 10:26:28 11680 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2019-03-14 10:26:28 11680 [Note] InnoDB: The InnoDB memory heap is disabled
2019-03-14 10:26:28 11680 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-03-14 10:26:28 11680 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2019-03-14 10:26:28 11680 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-03-14 10:26:28 11680 [Note] InnoDB: Using generic crc32 instructions
2019-03-14 10:26:28 11680 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2019-03-14 10:26:28 11680 [Note] InnoDB: Completed initialization of buffer pool
2019-03-14 10:26:28 11680 [Note] InnoDB: Highest supported file format is Barracuda.
2019-03-14 10:26:28 11680 [Note] InnoDB: The log sequence number 1835037 in ibdata file do not match the log sequence number 154939577 in the ib_logfiles!
2019-03-14 10:26:29 11680 [ERROR] InnoDB: Attempted to open a previously opened tablespace. Previous tablespace concierge/countries uses space ID: 94 at filepath: .\concierge\countries.ibd. Cannot open tablespace fint/default_paybacks#p#p24 which uses space ID: 94 at filepath: .\fint\default_paybacks#p#p24.ibd
InnoDB: Error: could not open single-table tablespace file .\fint\default_paybacks#p#p24.ibd
InnoDB: We do not continue the crash recovery, because the table may become
InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it.
InnoDB: To fix the problem and start mysqld:
InnoDB: 1) If there is a permission problem in the file and mysqld cannot
InnoDB: open the file, you should modify the permissions.
InnoDB: 2) If the table is not needed, or you can restore it from a backup,
InnoDB: then you can remove the .ibd file, and InnoDB will do a normal
InnoDB: crash recovery and ignore that table.
InnoDB: 3) If the file system or the disk is broken, and you cannot remove
InnoDB: the .ibd file, you can set innodb_force_recovery > 0 in my.cnf
InnoDB: and force InnoDB to continue crash recovery here.
190314 10:26:29 [ERROR] mysqld got exception 0x80000003 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.

To report this bug, see https://mariadb.com/kb/en/reporting-bugs

We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

Server version: 10.1.38-MariaDB
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 787931 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
  • Well to get rid of this one Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator. Just remove the line innodb_additional_mem_pool_size from the my.ini file – RiggsFolly Mar 14 at 12:02
  • Then start at this line To fix the problem and start mysqld: and read what it says – RiggsFolly Mar 14 at 12:04
  • 1
    Basically you have a corrupted table and you need to carefully attempt recovery. OR it would be easier to just restore your Latest Backup for this database – RiggsFolly Mar 14 at 12:05

Suggestion for your my.cnf [mysqld] section

KERNEL32.DLL!BaseThreadInitThunk() being involved can sometimes be resolved by knowing your thread_cache_size and doubling the value.

SELECT @@thread_cache_size;

to determine current value and with root login,

SET GLOBAL thread_cache_size=thread_cache_size*2;

try your process and if it works adjust your my.cnf (or my.ini) to the new/tested value for future stop/start of your instance to have higher thread cache capacity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy