6

New versions of pgAdmin 4 are being released every month, and it's so annoying to see a popup with notification about another update. There's no option in preferences to disable it. Is there a trick to disable this particular popup, except installing the new version?

enter image description here

9

Add this line to config_local.py and restart the pgadmin4:

UPGRADE_CHECK_ENABLED=False

Note: The location of config_local.py is same as config.py. You can find the location of config.py with this command in linux:

$ find / -wholename "*/web/config.py" 2>/dev/null

If the config_local.py file doesn't exist yet, you can create one.

| improve this answer | |
  • 2
    The solution works! The only note is that, as I work on Mac, my config is stored in /Applications/pgAdmin 4.app/Contents/Resources/web/config_local.py – Yaroslav Jul 8 '19 at 7:48
  • 1
    On windows as well. Whereever the pgAdmin4.exe file is in the folder above that is a folder called "web" and there it is – Hobbamok Jul 5 at 19:44
3

In Windows you can change this value directly in the config.py file found in: \%ProgramFiles%\PostgreSQL\version\pgAdmin\web**config.py**

| improve this answer | |
1

If you're using the dpage/pgadmin4 Docker image, adding an environment variable disabled the check and notification.

PGADMIN_CONFIG_UPGRADE_CHECK_ENABLED=False

PGADMIN_CONFIG_ is further documented at:

https://www.pgadmin.org/docs/pgadmin4/latest/container_deployment.html

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.