0

I have configured "Always On" on SQL server 2017, and also created a backup maintenance job using the wizard, but when I executed the backup job I got following error:

Could not process the operation. Always On Availability Groups does not have permissions to access the Windows Server Failover Clustering (WSFC) cluster.
Disable and re-enable Always On Availability Groups by using the SQL Server Configuration Manager. Then, restart the SQL Server service, and retry current operation.

I disabled/enabled always on but still get the same error.

Any thought?

6
  • What's the output of the following powershell command run locally on a cluster node exhibiting the behavior? get-clusteraccess | Where-Object{$_.IdentityReference -like "*SQLServerHADRUser*"} – Sean Gallardy - Retired User Mar 14 '19 at 23:54
  • 1
    Is you Availability Group built on a Windows Failover Cluster, or is it Clusterless? – HandyD Mar 15 '19 at 0:05
  • @HandyD If it's clusterless it won't attempt to use the cluster. Not sure where you were going with this one. – Sean Gallardy - Retired User Mar 15 '19 at 0:46
  • 2
    @SeanGallardy there is a known issue in clusterless AGs that throws this exact error when querying the fn_hadr_backup_is_preferred_replica function. Could be OPs issue if they're using clusterless AG. [Link] (feedback.azure.com/forums/908035-sql-server/suggestions/…) – HandyD Mar 15 '19 at 1:30
  • @HandyD Nice catch :) I think you're on to something. – Sean Gallardy - Retired User Mar 15 '19 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.