1

I downloaded and installed phpMyAdmin 4.8.5 on my windows. Upon opening it in the browser, it immediately asks for a Username and Password. I tried to submit root for username while leaving the password black. I even try password as password. Unluckily, both didn't work by default.

So I checked the web and I saw this from stackoverlow. Unfortunately, all of the given answers did not work for me and hello no, the thread is already closed.

0
1

Here's what I did

  1. Open phpmyadmin directory
  2. You will see config.sample.inc php file
  3. Clone it, but remove the sample from the title
  4. After cloning, open the file config.inc and look for $cfg['Servers'][$i]['AllowNoPassword'] = false;
  5. Set it to true

By doing this, we are allowing the phpMyAdmin to submit an empty password.

Now, try root as a username and leave the password blank.

Hope this will work for you as well.

1
  • It says /* Uncomment the following to enable logging in to passwordless accounts, * after taking note of the associated security risks. */ Sep 17 at 13:22
0

By default, root is not allowed to login with password but with an auth_socket plugin.

The solution is to change that behavior by running next command in mysql (login to mysql first)

ALTER USER 'root'@'localhost' IDENTIFIED WITH caching_sha2_password BY 'password';

Securing phpMyAdmin on Ubuntu provides additional details.

-1

Username: Root
Password: Empty- Nothing to write, Click Enter

1
  • Thank you for giving time to answer, but it is clear on the post that I already tried the solution you gave even before you post it.
    – SMPLYJR
    Mar 18 '19 at 0:22
-1

It might be that you have not installed all Visual C++ Packages.The package cab be found on below link. http://wampserver.aviatechno.net/?lang=en&prerequis=afficher

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.