0

I have Oracle 12c running on Windows 7.

When I look at the Oracle's specific services (Control Panel\System and Security\Administrative Tools\Services), I have the following 6 services:

enter image description here

So far, everything is normal. I can even start or stop every service by double clicking on it, and then clicking the Start/Stop button. However, for convenience, I want to create a .bat file with commands to open/close all the services. I run in command prompt commands such as net stop [service], and they all work fine except for OracleRemExecServiceV2.

enter image description here

As you can see, I get System error 5 - access is denied. How can I solve this problem?

UPDATE:

i ran cmd as admin. Please see the below screenshot. In the Services window, OracleRemExecServiceV2 remains in the 'Starting' state for a long time, without changing to 'Started'.

enter image description here

One more thing: i double clicked the OracleRemExecServiceV2 and, in the General tab, i noticed that the Path was something like C:... (i cannot remember), while the database is installed on D, and all the other five Oracle services have the Path beginning with D:\app\OracleHomeUser\product\12.1.0\dbhome\BIN. So i changed it accordingly, to point to RemoteExecService.exe in the BIN folder in the D directory. Is it ok what I did? otherwise, what would be the normal value for the path of this service?

0

TASKKILL /IM RemoteExecService.exe /F

It's placed in C:\Temp\2\\oraremservicev2\RemoteExecService.exe.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\OracleRemExecServiceV2]

  • in my case, RemoteExecService.exe is placed under OracleHomeUser\product\12.1.0\dbhome_1\BIN ; however, the command taskkill worked just fine – wile the coyote May 2 at 7:46
0

Use a command line started with administrator privileges.

enter image description here

  • I tried what you said, and I have appended a printscreen to the question – wile the coyote Mar 21 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.