3

I'm trying to setup a command-line call to dtexec to validate packages, using the project model. I'm calling dtexec like this:

dtexec /val /proj my.ispac /pack my.dtsx  /rep v 

Though the real paths to the ispac and dtsx are longer. WHen I run this, all I see on the console is:

Microsoft (R) SQL Server Execute Package Utility
Version 11.0.7001.0 for 32-bit
Copyright (C) 2016 Microsoft. All rights reserved.

Started:  10:40:01 AM
PS D:\>

The whole thing runs in under a second which leads me to believe that it did nothing. And no messages of any kind are issued., even though I asked for verbose reporting.

Any ideas out there as to how to make this work?

0

You are almost there, the syntax you are using is correct by you cannot use an abbreviation /Val. From the official documentation, you can see that:

/Rep[orting] level [;event_guid_or_name[;event_guid_or_name[...]]

/Pack[age] PackageName: (Optional). Specifies the package that is executed.

/Rep[orting] level [;event_guid_or_name[;event_guid_or_name[...]]

/Proj[ect] ProjectFile: (Optional). Specifies the project from which to retrieve the package that is executed.

Validation and execution phase: The package is run, or validated without running if the /VALIDATE option was specified.

Also note that when executing package from a project don't add the package extension .dtsx

Based on that try to use the following command:

dtexec /Proj my.ispac /Pack my  /Rep V  /VALIDATE
  • 1
    Ok -- the funny thing is that no error messages are issued. nothing at all. Also /val works just fine. you don't need the whole word or the caps. The real issue is adding specifying the full package name including the dtsx. Weird that no error messages are issued though! – user1443098 Apr 2 at 16:43
  • @user1443098 ok i reduced the quotes :). It looks like you already solved the issue. Why you didn't write an answer? – Hadi Apr 2 at 17:30
  • Well, I don't really have an answer. The question is why does it return immediately without messages? I still don't know. I think that it has something to do with the package name, but why it doesn't issue any messages is a mystery to me. I want error messages if the program can't run with the given parameters. still I guess that's a partial answer. – user1443098 Apr 2 at 18:11
0

When you run dtexec with the parameters I used, you cannot specify the file extension .dtsx with the package name. That causes the program to exit immediately, without error messages.

Why dtexec doesn't issue some kind of error message, as I feel it should, remains a mystery.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.