I am using postgresql 10.7 under AWS RDS.

I downloaded pgtap-1.0.0.zip from https://pgxn.org/dist/pgtap/ because I saw an article in AWS forums saying you can just run pgtap.sql yourself.

However, in the zip file there is no pgtap.sql but a pgtap.sql.in...

I am using a Windows client. Tried to run make in wsl but complains about "pg_config: not found" while there is a pg_config.EXE in my PATH.

It did produce a pgtap.sql but running it fails on view "tap_funky" because it tries to use a non existing column pg_catalog.pg_proc.prokind

I replaced the missing prokind column by a hard coded "f" for (normal function) and got something apparently working but it creates everything in the public schema.

I tried to run that script in a specific schema "pgtap" but it failed straight way. Is there a proper way to do this?


1 Answer 1


As of May 2019 pgTAP is an extension in RDS postgres version 11.2, (not version 10,7 however) according to https://aws.amazon.com/about-aws/whats-new/2019/05/amazon-rds-postgresql-supports-minor-version-112/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.