I have installed sql server express edition 2014 on my machine. And I am connecting to it with CRM using my local machine's IP address.

The problem here is my IP address allocated to my machine is dynamic and changes every day when I log in, which makes it impossible for me to connect to CRM (as the IP address changes obviously).

What to do in that case? Any help will be appreciated.

  • What to do in that case? Use static address if possible, or static lease otherwise. Ask your system/network administrator for it.
    – Akina
    Mar 27, 2019 at 12:41
  • I did that but it creates other problems like i am not able to connect to internet/ ip conflict with other systems etc. can you suggest anything else apart from that please. Mar 27, 2019 at 12:43
  • 1
    Can you not use a net name or computer name (IE DNS Name) Mar 27, 2019 at 12:45
  • i am not able to connect to internet/ ip conflict with other systems etc. This means that you set some static address within DHCP scope by yourself, without consult with admins. It's basically a diversion. Contact administrator group of your network. They will give you personal static address or will set static lease for your station.
    – Akina
    Mar 27, 2019 at 12:45
  • And one more variant is to install virtual machine and move SQL server into it. It will not interfere with your network.
    – Akina
    Mar 27, 2019 at 12:49

2 Answers 2


Instead of connecting via IP address, connect to your machine's name. If you're connecting locally, you can use LOCALHOST as the name, or just a period ("."), which connects you to your local default instance.

  • Loopback address may be not safe for OP. If you offer to change the connection properties, it will be more logical option to work through named pipes.
    – Akina
    Mar 27, 2019 at 13:20
  • Why would it not be safe?
    – Brent Ozar
    Mar 27, 2019 at 13:26
  • Not would. May.
    – Akina
    Mar 27, 2019 at 13:31
  • 1
    Right, why may it not be safe? You need to be more specific when you're casting someone's answer as not safe.
    – Brent Ozar
    Mar 27, 2019 at 13:52
  • I think CRM which OP uses tells about localhost in the documentation for configuring the connection. Often localhost is default address for connection settings. But OP uses NIC's address. Why? I had met at least 2 software products which refuses to work via localhost with error similar to "invalid address". That's why I suggested that localhost might not be safe option.
    – Akina
    Mar 27, 2019 at 16:43

Brent's suggestions of using your machine name, or LOCALHOST or just "." are all great ones, I would also suggest using the loop back address of

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.