-1

My payroll application developed in ASP.net and C language not able to connect the database. Our Payroll is broadcast through IIS, after we change our router i can't access this TimeCardUploader. How can I Reconnect my Database?

enter image description here

Every time I re-start the application I see this error.

A Connection was successfully established with the server,.
but then an error occurred during the login process.
(provider: Shared Memory Provider, error:0-No process is on the other end of the pipe

And our biometric server is stopped.

Thank you.

Best Regard.

  • Please check database status, whether it's available or down? – Rajesh Ranjan Mar 30 at 3:30
  • It says, " A Connection was successfully established with the server, but then an error occured during the login process. (provider: Shared Memory Provider, error:0-No process is on the other end of the pipe" And our biometric server is stopped, Everytime i try to restart, it stop – John Carl Mogol Mar 30 at 3:36
  • Check whether the SQL login you are using to connect database is enabled. – Rajesh Ranjan Mar 30 at 3:43
  • Did you check SQL Login? whether it's enabled or disabled? – Rajesh Ranjan Mar 30 at 5:26
  • where can i check that sir?, – John Carl Mogol Mar 30 at 6:42
0

First check if SQL Server is up and running on the database server.

If yes, then check if Shared memory/TCP-IP/Named pipes protocol is enabled on SQL Server. You can check that in SQL Server configuration manager. If it is not, then you have to enable it and then restart SQL Server service.

Also if you are using SQL login to connect to database, then you have to check if mixed mode authentication is enabled on SQL Server. To check that connect to SQL Server and right click on instance and go to properties -> security tab -> check if mixed mode authentication is enabled or not. This will again require SQL Server service restart to get the change reflected.

Check these 3 things first and let me know if it does not resolve your problem.

Please mark this solution as Solution, if it resolves your issue.

  • I just check the details sir, the all the pipes was already enabled, the mix mode is on, but in the server manager it is stop even if i try to start it won't start – John Carl Mogol Mar 30 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.