3

We have multiple m5 generation MySQL RDS instance. The problem we are facing is that while creating read replica for these instances we are repeatedly getting 'incompatible-restore' error. In the event log of read replica instance we are getting below error :

Database instance put into incompatible-restore. Your MySql memory setting is inappropriate for the usages

However, if we set the parameter group to 'default-5.7' then the read replica gets successfully created.

We have found the differences between the current parameter group and 'default-5.7' and tried to make those changes. But still the issue persists.

  • In one of the instances, reducing the key_buffer_size helped resolve the issue. But the same trick is not working in the other instances. – Subrata Das Apr 2 at 9:30
  • In one of the other instance, reducing the sort_buffer_size and read_rnd_buffer_size to their default values solved the issue. But still, no idea what is causing it in the first place. – Subrata Das Apr 3 at 8:06
  • Did you set it in the primary? Changing those for our primary is pretty risky :/ – Juliano Apr 3 at 18:51
  • @Juliano Sorry, but I did not understand what you meant by "primary"? And why is it risky? – Subrata Das Apr 4 at 7:29
  • primary = master in the replication topology, it's risky bc our master is usually under heavy load and I see a possibility of changing those, making performance worse, snowballing and bringing the site down – Juliano Apr 4 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.