0

One of our team member wanted to create a Managed instance for his testing and was asked to use existing vnet which was already configured to connect remotely and had other Managed instances for POC.

While building he checked the 'Prepare subnet for Managed instance'. The deployment which should not have taken more than an hour took 6-7 hours and we knew it has done some changes that will cause issues. The deployment was successful and managed instance is up and running.

The real issue :

We can't connect to the MI remotely from the domain anymore. We are investigating ,but would really be helpful if anyone can point out what it would be.

(PS: I am weak in Networksconcepts)

2 Answers 2

2

For POC, you can also try the public endpoint which is now available and can be configured through PowerShell. https://techcommunity.microsoft.com/t5/Azure-SQL-Database/Public-endpoint-for-SQL-Database-Managed-Instance-is-available/ba-p/438996

0

Unable to connect SQL Managed instance in the vnet

As per MSDN BOL here the VMs on your subnets cannot communicate with your SQL Database. One action that establishes the communication is the creation of a virtual network rule. The rationale for choosing the VNet rule approach requires a compare-and-contrast discussion involving the competing security options offered by the firewall.

  • Allow access to Azure services
  • IP rules

You can salvage the IP option by obtaining a static IP address for your VM. For details, see Configure private IP addresses for a virtual machine by using the Azure portal.

In some cases the Azure SQL Database and the VNet-subnet are in different subscriptions. In these cases you must ensure the following configurations:

  • Both subscriptions must be in the same Azure Active Directory tenant.
  • The user has the required permissions to initiate operations, such as enabling service endpoints and adding a VNet-subnet to the given Server.
  • Both subscriptions must have the Microsoft.Sql provider registered.

For further your ref here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.