0

I am currently trying to carry out a database migration from SQL Server 2008 to SQL Server 2017 (Linux) using the DMA tool.

I get the all green after running the assessment, however I get hit with an "out of memory" exception during the migration process.

Any advice on how I can resolve this issue? Both source and destination servers have 16GBs of RAM. This should be sufficient, no?

1

There is a similar, but not exactly the same, question here:

Azure SQL Data Migration Assistant is Stuck on "Migrate Data"

However, it does explain the limitation you're hitting:

The Extract service connects to a database, reads all of its objects and their properties, and then creates an in-memory model of the database.

If the database you're trying to migrate has an exceptional number of schema objects, this in-memory DAC model potentially overwhelms the client application / system (Data Migration Assistant running on your PC in this case), resulting in the OutOfMemoryException.

Your next best bet would be to use tried and true approaches like backup / restore in order to migrate to the new machine.

1

This is how I resolved the issue. I took the backup/restore route after the DMA tool did not work. I was restoring the backup made on SQL Server 2008 to Server 2017(Linux version), and I get this error at the tail end of the restore process.

There is insufficient system memory in resource pool 'internal' to run this query. Msg 3013, Level 16, State 1, Server solarwinds-DB2, Line 1 RESTORE DATABASE is terminating abnormally.

Apparently, this issue has been encountered by a number of people trying to do same (seems to be a bug). The workaround was to restore the database to SQL Server 2017 (Windows version), take a backup, and then do the restore to SQL Server 2017 (Linux version). It works now.

  • Sorry, I read that we can't backup/restore from sql server 2008 (100) to sql server 2017. were you able to do this ? just a backup/restore? – Racer SQL Aug 7 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.