I have issue with mongod service after adding keyFile in config. I follow instruction from here : https://docs.mongodb.com/manual/tutorial/deploy-replica-set-with-keyfile-access-control/

after adding keyFile in config, and restart the service, it give me this error :

ERROR: child process failed, exited with error number 1

I already set chmod 400 to the keyfile and set permission to mongod. Also have check and follow instruction from this https://dba.stackexchange.com/a/174014, but still no luck

anyone maybe know what is the problem that causing that error? Thanks in advance

  • The reason for your error should be logged in the log file specified in the --logpath parameter. Please update the question with the error message details.
    – Mani
    Commented Apr 18, 2019 at 15:24

1 Answer 1


As here Mr. onetwopunch said that I had the same thing and it turned out to be a permissions issue .If the owner of the child process cannot access the log path or the log path does not exist, it will fail.

What I did was put the log directory in my home directory:

mkdir ~/log
mongod --fork --logpath ~/log/mongodb.log

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.