2

I have downloaded Oracle XE 11.2.0-1.0 and installed it on a CentOS 6.3 virtual machine with 1.5GB memory and 3GB of swap.

SYS and SYSTEM set to have password 123456. I have set ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe/ and ORACLE_SID=XE.

I can connect to this database with SQL Developer with the SYSTEM user. But when I want to connect with sqlplus it says:

ERROR.
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Linux-x86_64 Error: 2: No such file or directory
Process ID: 0
Session ID: 0 Serial number: 0

ps -fe | grep pmon shows this:

oracle    1164    1    0    11:26    ?    00:00:00    xe_pmon_XE

I have logged in as root user and I just type sqlplus with no arguments then it asks for user name and password.

Can anyone help?

5
  • That usually means you haven't started Oracle (but the listener is running).
    – user1822
    Sep 3, 2012 at 6:39
  • @a_horse_with_no_name I can create tables, ... in the database using sql developer. Sep 3, 2012 at 6:46
  • is there a pmon process running? what is the output of ps -fe|grep pmon? I am not familiar with sqldeveloper. what connection data do you use to connect to the system?
    – miracle173
    Sep 3, 2012 at 6:47
  • i misread your post. how do you connect with sqlplus?
    – miracle173
    Sep 3, 2012 at 6:48
  • Then your connection using SQLPlus is wrong. Please show us the connection details you use in SQL Developer and SQLPlus
    – user1822
    Sep 3, 2012 at 6:55

1 Answer 1

2

I have removed the trailing / from ORACLE_HOME and it solved my problem.

1
  • This is the only solution that worked for me!
    – daisy
    Jan 29, 2016 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.