1

I have a Windows 2012 R2 Datacenter cluster environment. With active Passive nodes of SQL Server 2012 SP4.

I am trying to upgrade the SQl Server from 2012 SP4 to 2016 SP2. I am performing in-place upgradation first on Passive node and then on active node.

My installation failed with below error. Error: the cluster resource is not online. Bring analysis service server online before starting upgrading process

Error Message

I have analysis services install on both the instance node. First the Analysis service was stopped when I got the error, So I started the analysis services and re run the installation but it failed with same error.

Since analysis services are not required I tried to remove the feature but guess we cant add or remove features from 2012 cluster environment.

So, Basically I am stuck here and dont know how to proceed with the installation.

Can anyone please help me out!!

Thanks in advance.


@Learning_DBAdmin Following you lead, i checked for dependencies and found there are no dependencies on analysis services.

enter image description here

Also i dont see analysis service resource in roles tab in failover cluster manager. enter image description here

Is it posssible that i havent properly configured the analysis services on the server?

Following your previous link i came to know that i need to create SSAS generic resource manually in the failover cluster manager. Can you help me to create SSAS generic resource in failover cluster manager.

Thanks in advance.

  • Which account you are using to start SQL service and SSAS? Is it domain account or NT account? – Learning_DBAdmin May 5 at 4:55
  • Its a domain account with sys admin rights – Aditya Sawant May 5 at 5:09
  • Please post the error(s) from your bootstrap logs. They will contain much more detail and would help provide better context. – John Eisbrener May 6 at 0:51
  • 1
    I am not sure if it would help you, but how to setup analysis service as a generic cluster resource is described here mssqltips.com/sqlservertip/3692/… – eckes May 6 at 5:06
  • My problem here is Analysis services are already installed (during installation of SQL Server instance) I can see it in my configuration manager (Done by pervios vendors have no idea how they istalled). As per your link analsysis servies role is automatically added from the steup file of sql server but in my case SSAS is already installed still I am not able to see in the roles section in Failover cluster manager. – Aditya Sawant May 6 at 5:52
2

Ideally in-place upgrade is not very much recommended as this poses multiple risk and has potential to bring your whole database down. You may perform the same on a different server using existing set-up and replace the old servers with new server(set-up) in your go-live activity.

Having said above, few customers go for this upgrade in order to save licensing and servers. From the error message, its very clear that MSSQL service is having dependency on SSAS. Please refer the below screenshot of dependency tab:

No Dependency:

SSAS with No Dependency

With Dependency:

  1. Service depends on other service:

[Dependency 1[2]

  1. Other service depends on this service:

Dependency 2

Based on terminology, I hope its clear that what service depends on other service.

This error would have been logged in either summary or detail log as described here at Mr. Pinal Dave's article:

https://blog.sqlauthority.com/2017/06/20/sql-server-upgrade-failure-cluster-resource-not-online-bring-analysis-services-server-online-starting-upgrade-process/

This also suggests that there was something wrong with the installation, meaning same set of SQL components are not available on active and passive nodes.

As you have already confirmed from the comments that it has worked, you may find details about dependencies above.

I hope above helps.

  • Have checked the summery.txt. The error is exect same wich is provided in Mr. Pinal Dave blog whic you provided blog.sqlauthority.com/2017/06/20/… – Aditya Sawant May 6 at 5:50
  • So, did it not help after following the steps mentioned at his blog. – Learning_DBAdmin May 6 at 14:36
  • I have to create a generic serive resource for SSAS. Confusion is I found 2 ways to do that from failover cluster manager. 1st way is to right click on "Roles" goto "Configure role" select Generic Service and then select analysis services of that instance but here I require a new network name and IP and assig a disk guess doing this will create a new role for SSAS. 2nd was is to righ click on the instance role itself "Add resource" then "Generic service" doing this doesnot require any network name or IP and this will not create new role it will be displace under current role resource. – Aditya Sawant May 8 at 4:25
  • I am not sure which way to use from above mentioned 2 ways. – Aditya Sawant May 8 at 4:28
  • This is a different issue. You may ask this as a new question and experts will advise. – Learning_DBAdmin May 8 at 5:49
0

Thank you all your inputs and help.

We have successfull upgraded out SQL Serevr 2012 clustered instance to SQL Server 2016 Clustered instance.

As mentioned we were facing belwo error while upgrading the instance. Error: the cluster resource is not online. Bring analysis service server online before starting upgrading process

This was becaused there was no resource present for SSAS in failover cluster manager. To overcome this we have created a generic service for SSAS in the instance role. Refer belwo screen shot.

Step1: enter image description here

Step2: enter image description here

Select SQL Server Analysis Services from the list above and click next to complete the configuration.

Once it is completed you will see SSAS generic role create in resource tab of the SQl Srever instance role. enter image description here

You just need to brink the service online by right clicking on it and its done!!! You acn now re run the installtion file and completed the upgradation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.