1

When I open pgAdmin4 v4 on Windows 10, the dashboard displays
An error occured whilst rendering the graph
on all charts. The link (1) told me that the logs on windows are at
Windows log location: C:\Users\YOUR_USERNAME\AppData\Roaming\pgAdmin\pgadmin4.log
The logs contained numerous times the same error

2019-05-10 10:01:32,139: ERROR  flask.app:  string indices must be integers
Traceback (most recent call last):
  File "C:/Program Files (x86)/pgAdmin 4/v4/venv/Lib/site-packages\flask\app.py", line 1813, in full_dispatch_request
    rv = self.dispatch_request()
  File "C:/Program Files (x86)/pgAdmin 4/v4/venv/Lib/site-packages\flask\app.py", line 1799, in dispatch_request
    return self.view_functions[rule.endpoint](**req.view_args)
  File "C:/Program Files (x86)/pgAdmin 4/v4/venv/Lib/site-packages\flask_login\utils.py", line 261, in decorated_view
    return func(*args, **kwargs)
  File "C:\Program Files (x86)\pgAdmin 4\v4\web\pgadmin\dashboard\__init__.py", line 251, in wrap
    return f(*args, **kwargs)
  File "C:\Program Files (x86)\pgAdmin 4\v4\web\pgadmin\dashboard\__init__.py", line 371, in dashboard_stats
    for chart_row in res['rows']:
TypeError: string indices must be integers

I can also not open any databases(pressing the databases button doesn't unfold the list of databases) via pgAdmin4 v4.

Since I was working with the permissions of my users on certain databases, this has probably to do with it. The commands I recall running are

REVOKE ALL ON DATABASE Database_Name FROM Database_User;
REVOKE ALL ON DATABASE Database_Name FROM PUBLIC;

To verify that I did not completly corrupt my databases and the error is just weird I logged in with the admin user via psql. Running \du and \l did not show anything was off.

What Should I do to fix this?

(1) https://stackoverflow.com/questions/41766323/pgadmin4-dashboard-does-not-display-sessions

-- edit --
DataGrip doesn't seem to have the problem either.

1

I have the same problem in Ubuntu 18.04 with pgAdmin 4.11 and postgres 11.

What works for me is to go to the process list and kill the pgadmin4 process and reload it. You may do it from Task Manager on windows. Good luck.

BTW Datagrip always work fine for me too.

0

Please use Internet Explorer for this issue. I have same error message on Google chrome. My chrome version is Version 77.0.3865.90 (Official Build) (64-bit)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.