1

I'have just completed oracle 11g database software installation on Linux. I launched netca and configured a listener. As soon as I try to run lsnrctl I get the following error.

[oracle@lnx-db ~]$ lsnrctl

LSNRCTL for Linux: Version 11.2.0.1.0 - Production on 10-MAY-2019 15:34:41

Copyright (c) 1991, 2009, Oracle.  All rights reserved.

Message 850 not found; No message file for product=network, facility=NL

The environment variables seem to me set correctly.

[oracle@lnx-db ~]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


[oracle@lnx-db ~]$ echo $ORACLE_HOME $ORACLE_SID $ORACLE_BASE
/u01/app/oracle/product/11.2.0/dbhome_1 ORCL /u01/app/oracle

From what I read on https://community.oracle.com/thread/2322893?tstart=0 it could be a problem with the mesg but files seems there and readable.

[oracle@lnx-db ~]$ file $ORACLE_HOME/network/mesg/*
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/naukus.msb: data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/naukus.msg: ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/ncrus.msb:  data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/ncrus.msg:  ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/niqus.msb:  data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/niqus.msg:  ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nlus.msb:   data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nlus.msg:   ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nmpus.msb:  data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nmpus.msg:  ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nmrus.msb:  data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nmrus.msg:  ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nnfus.msb:  data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nnfus.msg:  ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/nnlus.msg:  ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/snlus.msb:  data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/snlus.msg:  ASCII English text
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/tnsus.msb:  data
/u01/app/oracle/product/11.2.0/dbhome_1/network/mesg/tnsus.msg:  ASCII English text

Any hints?

EDIT1: As suggested below I've checked NLS_LANG and TNS_ADMIN variables. Both are not set. But settings them does not fix the problem:

[oracle@lnx-db u01]$ echo $NLS_LANG $TNS_ADMIN ; lsnrctl
American_America.UTF8 /u01/app/oracle/product/11.2.0/dbhome_1/network/admin

LSNRCTL for Linux: Version 11.2.0.1.0 - Production on 10-MAY-2019 16:16:05

Copyright (c) 1991, 2009, Oracle.  All rights reserved.

Message 850 not found; No message file for product=network, facility=NL
LSNRCTL> q
  • Just out of curiosity why are you installing 11.2.0.1 which is already out of support? – kevinsky May 10 at 13:58
  • @kevinsky I'd like to be able to tell you that it's for migration tests to a newer version but sadly it's a requirement – sgargel May 10 at 14:00
  • 1
    What's NLS_LANG set to? And TNS_ADMIN ? You can also try running lsnrctl under strace to see which files it's actually looking for (and failing to find) – Philᵀᴹ May 10 at 14:05
  • Variables was setted but not correctly exported! – sgargel May 10 at 15:13
  • 1
    In over 20 years of working with Oracle, I have never known this error to be anything other than an incorrect setting of ORACLE_HOME. What you show for ORACLE_HOME looks reasonable, so the next thing I'd want to check is to make sure that it is correctly set within the session from which you start 'lsnrctl'. Please edit your op to clearly show these two command within the same session: 'env | grep ORA' and ' lsnrctl status'. – EdStevens May 11 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.