0

I have Percona fork of MySQL 5.7 installed where I have defined innodb_buffer_pool_size in /etc/percona-server.conf.d/mysqld.cnf as follows

innodb_buffer_pool_size = 10G

But, when I login to MySQL prompt and run command show global variables like 'innodb_buffer_pool_size' it shows as follows

mysql> show global variables like 'innodb_buffer_pool_size';
+-------------------------+-----------+
| Variable_name           | Value     |
+-------------------------+-----------+
| innodb_buffer_pool_size | 134217728 |
+-------------------------+-----------+
1 row in set (0.00 sec)

and no matter what value I set in /etc/percona-server.conf.d/mysqld.cnf for innodb_buffer_pool_size the value for innodb_buffer_pool_size in MySQL prompt remains same.

Also, when I run show global variables like 'innodb_buffer_pool_%size' in MySQL prompt it shows as follows

mysql> show global variables like 'innodb_buffer_pool_%size' ;
+-------------------------------+-----------+
| Variable_name                 | Value     |
+-------------------------------+-----------+
| innodb_buffer_pool_chunk_size | 134217728 |
| innodb_buffer_pool_size       | 134217728 |
+-------------------------------+-----------+
2 rows in set (0.00 sec)

Can someone tell me why innodb_buffer_pool_size value is not changing? while I have enough memory on my server.

  • When you restarted the server did you get any parse errors in the conf file? – raphael75 May 10 at 14:08
  • 1
    Are you certain you're editing the correct file? Run: mysqld --verbose --help | grep -A 1 "Default options" – Philᵀᴹ May 10 at 14:09
  • @Philᵀᴹ Yes, when I run command mysqld --verbose --help | grep -A 1 "Default options" I did not find the path for /etc/percona-server.conf.d so I had to add !includedir /etc/percona-server.conf.d in the end of /etc/my.cnf and then it worked. But, I am just curious about, if lets say symbolic-links=0 or datadir is defined in both files then which one will take precedence and why? – Farmi May 10 at 16:17
0

Repeating the above comment to provide an "answer" for this question: The config file /etc/percona-server.conf.d/mysqld.cnf was not being included in the standard "global config" file, commonly known at /etc/my.cnf. @OP added !includedir /etc/percona-server.conf.d to the end of the global config and then the changes were visible upon restart of MySQL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.