0

Problem is just as the title says.

pg_dump literally can't write to anywhere on drive C: - the drive windows is installed on.


More details:

  • created Temp folder on C: drive

  • modified access - added user EVERYONE with Full Permissions

  • running pg_dump.exe --file "c:\\Temp" --host "localhost" --port "5432" --username "postgres" --verbose --format=c --blobs "ldmgmt"

Result:

pg_dump: [custom archiver] could not open output file "c:\\Temp": Permission denied

But if I change drive to D: - it works.

Anyone knows how to make it write to drive C:?

  • 2
    Try adding a file name to the file string for the file parameter. It is probably trying to write to a file on the c drive called temp and not to a file in the temp folder – Aaron May 11 at 20:02
  • @Aaron You are absolutely right. I can't believe I am so goddamn stupid. Oh, I should really learn to pay attention to smallest details, otherwise I'll be doomed. Thank you so much! Feel free to post an answer and I'll accept & upvote it with great pleasure. – Alex Herman May 11 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.