0

I installed Oracle Client 12.2.0.1 (x32) on a Win7 x64 machine. When I tried to create an ODBC by invoking "C:\Windows\SysWOW64\odbcad32.exe" and picking the "Oracle Client" from the list and clicked "Next", I immediately get this error message:

"... ODBC driver could not be loaded due to system error code 126: The specified module could not be found C:\app\client\oracle\product\12.2.0\client_1\BIN\SQORAS32.DLL)"

I have been Googling around and people were able to resolve this issue by installing Visual C++ Redistributable 2013 for Oracle Client 12.2.0.1. I downloaded and installed but still get the error.

https://www.microsoft.com/en-us/download/details.aspx?id=40784

Does anyone have any idea what my problem could be?

  • at the risk of asking a silly question does this file exist and does the user have read and execute on it C:\app\client\oracle\product\12.2.0\client_1\BIN\SQORAS32.DLL – kevinsky May 14 '19 at 14:22
  • Yes, it's there. I also checked the registry under the "ODBC.INI" section for the Oracle Client home, it is pointing to that path as well. – sydney May 14 '19 at 14:23
  • Are the keys and the paths in the registry correct for the 32bit libraries on 64bit Windows? Wonder also if dependencywalker.com would help. – Colin 't Hart May 14 '19 at 15:00
  • I checked this registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI. Glad you brought up dependency walker. I ran dependency walker 2.2 (x32) and pointed to "SQORAS32.DLL". But it wasn't able to load. I thought that was weird. Just for the fun of it, i installed DW 2.2 for x64. Couldn't load it either. However, on another Win7 x64, i was able to. – sydney May 14 '19 at 15:05
  • This problem machine is Win7 x64 VM that I run at home. At work, i have Win7 x64 but Oracle Client 12.1.x and not 12.2.x. .. and yes, the registry points to the right path to "SQORAS32.DLL" and the registry key is the one i replied above. – sydney May 14 '19 at 15:07
1

After bashing my head for a good while, I could make the ODBC 32 bits run. It was the VC ++ 2013 Redistributable.

My install is version 12.2.0.1.0. I can't believe how stupidly hard it is to get the simple ODBC. You must uncompress the Instant CLient plus ODBC in the same folder and then manually install VCRedist to get this running. GEEEZ.

UPDATE: Adding a few extra details on my exact steps:

Download Oracle Instant client from the download portal: https://www.oracle.com/database/technologies/instant-client/downloads.html

Make sure you download the version that you need: X64 or X32. NOTE: DO NOT MIX THE x64 and X32 folders!!!

After you choose the x64 or x86 version, you will be presented with a huge list of packages. You want to make sure you scroll down to the proper version, in my case, it was 12.2.0.1.0.

You must download 2 packages:

  • Basic Package
  • ODBC Package

If you are installing x32 and x64, you must then download 4 packages:

  • Basic Package x32
  • ODBC Package x32
  • Basic Package x64
  • ODBC Package x64

Then, download and install VCredist 2010 and VCredist 2013. Here is a good resource to download them, for x32 you must install x32 bits VCRedist. https://www.itechtics.com/microsoft-visual-c-redistributable-versions-direct-download-links/

Then, you must uncompress the Basic and ODBC package in the same folder. DO NOT MIX x32 and x64, you must create separate folders if you are going to install both bit parity versions.

Then, open CMD as administrator, navigate to your uncompressed folder and run odbc_install.exe.

Then go to ODBC Datasources (Start menu, type ODBC) and add a new DSN, you will be presented with the Oracle ODBC screen. Here is a tutorial to create the DSN: http://dba.fyicenter.com/faq/oracle/Define-DSN-with-ODBC-Manager.html

That's it! the key part here is the VCRedist, if you don't have it, you will have the error stated by the Original Poster.

I hope this helps.

| improve this answer | |
  • that's very good, congratulations for finding the solution - can you add more details as how you got it working? – Marcello Miorelli May 15 at 10:15
  • 1
    @MarcelloMiorelli I have updated my answer to explain how I solved my issue. – Edwin Mejias May 16 at 12:54
  • +1 and it is a very good and useful piece of information – Marcello Miorelli May 16 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.