1

I installed Oracle Client 12.2.0.1 (x32) on a Win7 x64 machine. When I tried to create an ODBC by invoking "C:\Windows\SysWOW64\odbcad32.exe" and picking the "Oracle Client" from the list and clicked "Next", I immediately get this error message:

"... ODBC driver could not be loaded due to system error code 126: The specified module could not be found C:\app\client\oracle\product\12.2.0\client_1\BIN\SQORAS32.DLL)"

I have been Googling around and people were able to resolve this issue by installing Visual C++ Redistributable 2013 for Oracle Client 12.2.0.1. I downloaded and installed but still get the error.

https://www.microsoft.com/en-us/download/details.aspx?id=40784

Does anyone have any idea what my problem could be?

  • at the risk of asking a silly question does this file exist and does the user have read and execute on it C:\app\client\oracle\product\12.2.0\client_1\BIN\SQORAS32.DLL – kevinsky May 14 at 14:22
  • Yes, it's there. I also checked the registry under the "ODBC.INI" section for the Oracle Client home, it is pointing to that path as well. – sydney May 14 at 14:23
  • Are the keys and the paths in the registry correct for the 32bit libraries on 64bit Windows? Wonder also if dependencywalker.com would help. – Colin 't Hart May 14 at 15:00
  • I checked this registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI. Glad you brought up dependency walker. I ran dependency walker 2.2 (x32) and pointed to "SQORAS32.DLL". But it wasn't able to load. I thought that was weird. Just for the fun of it, i installed DW 2.2 for x64. Couldn't load it either. However, on another Win7 x64, i was able to. – sydney May 14 at 15:05
  • This problem machine is Win7 x64 VM that I run at home. At work, i have Win7 x64 but Oracle Client 12.1.x and not 12.2.x. .. and yes, the registry points to the right path to "SQORAS32.DLL" and the registry key is the one i replied above. – sydney May 14 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.