0

yes, i've read this SQL Server Management Studio 18 won't open (only splash screen pops up) , it work the first time. after i restart my computer, and try to open smss again, the problem happen again and i try to fix it like before, but now, it doesnt work.

this is my error log:

34 2019/05/19 23:14:19.298 Error VisualStudio CreateInstance failed for package [Async Query Service Package]Source: 'mscorlib' Description: Could not load file or assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) System.IO.FileLoadException: Could not load file or assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) File name: 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' at System.Reflection.RuntimeAssembly.GetType(RuntimeAssembly assembly, String name, Boolean throwOnError, Boolean ignoreCase, ObjectHandleOnStack type) at System.Reflection.RuntimeAssembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase) at System.Activator.CreateInstance(String assemblyString, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark) at System.Activator.CreateInstance(String assemblyName, String typeName) at System.AppDomain.CreateInstance(String assemblyName, String typeName) WRN: Assembly binding logging is turned OFF. To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1. Note: There is some performance penalty associated with assembly bind failure logging. To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog]. {DD7B74B5-C1F9-411A-B22E-5E711592BC6B}


80004005 - E_FAIL

what i get from there is saying that the program failed to find the dll, but, the dll exist.

  • I'm getting the same now, where do you find the error log? – neslekkiM May 22 at 11:32
  • You need to make your own log via CMD. "C:\Path\To\Your\Excutable\nameofexecutable.exe" -log C:\path\of\the\log\you\want\nameoflog.txt" Run in cmd – tns2307 May 26 at 15:10
  • By The Way, i've solved this problem by copying my friend's Microsoft.VisualStudio.Shell.Interop.8.0 – tns2307 May 26 at 15:13
  • Microsoft gave me this answer: feedback.azure.com/forums/908035/suggestions/37502512 Seems like there is an line that should be removed from configfile. But I copied the interop file from another place, seems to work. – neslekkiM May 27 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.