1

I have an rman database backup from Oracle 11g XE which i am trying to import into oracle 18c XE database using below commands

rman target /
shutdown abort;
startup nomount;
SET DBID DBID_FROM_ORACLE11G
restore controlfile from 'PATH_TO_CONTROL_FILE';
alter database mount;

After "alter database mount" I am getting below error

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of sql statement command at 05/29/2019 11:12:45
ORA-65101: container database set up incorrectly

Is there something I am missing or is there anything wrong with my procedure

2

Yes.

If you want to the save a lot of time and trouble, forget RMAN for this specific task. Oracle XE 11g is limited to 11 GB data. Data Pump can easily handle that.

Data Pump Export

Data Pump Import

  • Will datapump be able to export all the schemas including oracle apex along with the tablespaces and schema definitions etc? – ProgNi May 29 at 13:09
  • @ProgNi Data Pump can perform a full database export and import. Tablespaces, schemas are included, yes. For APEX, I would just install the latest available version in the 18c XE database, then export and import the applications, not the databases schema. – Balazs Papp May 29 at 14:27
  • APEX needs to be a minimum of 5.1.4 prior to upgrade – Michael Kutz May 29 at 16:27
  • I tried datapump export with full database export option but it didnt import tablespaces and gave error for , – ProgNi May 29 at 17:58
  • @BalazsPappActually there are lots of workspaces ids and application etc which will take a lot of time also i dont have access to all applications etc so it will be a problem to move them individually so i was hoping by using rman everything along with APEX will be moved – ProgNi May 30 at 9:07
1

I recommend you follow the instructions found in The Fine Manual.

Manuals

Recap of instructions

  1. (APEX) upgrade APEX to at least 5.1.4
  2. export via Data Pump
  3. uninstall 11g
  4. install 18c
  5. import into the PDB via Data Pump
  6. (APEX) run the apxfix.sql (see manual for location of script)
  • Thank you for pointing this out i will follow the steps and see if i missed something previously with datapump export – ProgNi May 29 at 18:00
  • I tested the installation guide as you have mentioned by exporting from 11g using expdp and then importing in another instance of 11g with already installed didn`t work. Then tried import to 11g with only database fresh install didnt work. Then checked importing to 18c and it didnt work , i am getting a lot of other errors other then which are mentioned in guide such as ORA-39082 , ORA-01917 , ORA-31625 . I am now completely out of ideas as to what is going wrong – ProgNi Jun 12 at 10:05
  • @ProgNi - Diagnosing your problem will probably by flagged as "too localized". I suggest asking on the Oracle forum for XE for your diagnostics questions ( community.oracle.com/community/groundbreakers/database/… ) – Michael Kutz Jun 12 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.