0

I am trying to install GI 19c on Oracle Linux 7 (required for 19c), and have used AsmLib to try to achieve device persistence (owner,group) for ASM devices/disks. Prior to that I used udev rules for the same and was able to achieve the same. Both times I get the same issue while doing ASM disk discovery as explained below.

Problem is when I try to invoke the gridSetup.sh from node 1, all checks pass including node readiness, ssh equivalence, scan etc, but the installer fails(not able to find the disks) at discovering ASM disks which are already marked by oracleasm(AsmLib) as asm disks and are owned by grid:oinstall.

screenshot of the gridSetup.sh installer which fails at disk discovery with the error 49802 initializing ADR

The installer logs from oui show the below.

WARNING:  [May 29, 2019 12:32:14 PM] SRVCTL not found as there is no Grid Infrastructure home on the box.
INFO:  [May 29, 2019 12:32:14 PM] Executing [/u01/app/19.0.0/grid/bin/kfod.bin, nohdr=true, verbose=true, op=dfltdstr]
INFO:  [May 29, 2019 12:32:14 PM] Starting Output Reader Threads for process /u01/app/19.0.0/grid/bin/kfod.bin
INFO:  [May 29, 2019 12:32:14 PM] The process /u01/app/19.0.0/grid/bin/kfod.bin exited with code 1
INFO:  [May 29, 2019 12:32:14 PM] Waiting for output processor threads to exit.
INFO:  [May 29, 2019 12:32:14 PM] Parsing Error 49802 initializing ADR
INFO:  [May 29, 2019 12:32:14 PM] Parsing ERROR!!! could not initialize the diag context

Already tried setting ORACLE_BASE env variable and added to path, so adrci is executable. Also verified owner and permissions, (oracle:oinstall)

Also checked on permissions for /u01/app/19.0.0/grid/bin/kfod.bin and they are executable by grid user.(grid:oinstall)

Also tried various different asm diskstrings like ORCL:VOL*, ORCL*, VOL*, /dev/oracleasm/disks/* etc, but none of them worked.

both nodes have 3 asm disks VOL1,2,3 stamped by AsmLib

FYI: This is a fresh install of 19c GI onto a 2 node RAC cluster, (2 freshly created virtualbox machines with shared disks) with no prior GI or RDBMS installations on.

Any help/assistance is greatly appreciated.

Thanks

  • 1
    So how did you stamp the disks? Does oracleasm-discover list them? – Balazs Papp May 30 at 7:05
  • yeah oracleasm listdisks shows VOL1 VOL2 VOL3 – n23n23 May 30 at 14:42
  • i used oracleasm configure -i to setup the ownership persistence and auto start on boot – n23n23 May 30 at 14:44
  • I am not interested in oracleasm listdisks. oracleasm listdisks can list the disks even if you have an incomplete installation/configuration. I am interested in the output of oracleasm-discover. – Balazs Papp May 30 at 15:09
  • From node 1 ========== [root@RAC4 ~]# oracleasm-discover Using ASMLib from /opt/oracle/extapi/64/asm/orcl/1/libasm.so [ASM Library - Generic Linux, version 2.0.12 (KABI_V2)] Discovered disk: ORCL:VOL1 [20969472 blocks (10736369664 bytes), maxio 512, integrity none] Discovered disk: ORCL:VOL2 [25163776 blocks (12883853312 bytes), maxio 512, integrity none] Discovered disk: ORCL:VOL3 [31455232 blocks (16105078784 bytes), maxio 512, integrity none] [root@RAC4 ~]# – n23n23 May 30 at 16:29
1

Execute the below command to change owner (from root to oracle) on the given directory:

chown -R oracle:oinstall /u01/app/19.0.0/grid/log

and run the installer again. It worked for me.

0

Click the button “Change discovery Path” and put /dev/oracleasm/disks/* and your disks will be there.

  • have already tried all that – n23n23 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.