0

I use pgadmin 4 and PostgreSQL

I try to restore a database from a save.

I have put the directory of my file save C:\Users\H2O\Desktop\temp_DB\ as a binary path in file preferences.

When I try to restore my db from my tar file (database -> restore) I have got this error.

'C:\Users\H2O\Desktop\temp_DB\pg_restore.exe' n'est pas reconnu en tant que commande interne (pg_restore is not recognize as an internal command)

Don't know where it comes from.


I use pg admin 4 and Postgresql


'"C:/Users/Public/Downloads/tempDB/ \pg_restore.exe"' n'est pas reconnu en tant que commande interne

1

The Binary Path in Preferences is for the Postgres binaries, not for the backup file. Revert the Binary Path to the default (probably C:\Program Files\PostgreSQL\$version\bin where you replace $version as appropriate for your installation).

Enter the path to the backup file in the Tools > Restore dialogue and not in Preferences.

  • In tools->restore i give the path to my file but it doesnt worksC:/Users/Public/Downloads/tempDB/ \pg_restore.exe --host "localhost" --port "5433" --username "postgres" --no-password --role "postgres" --dbname "dvdrental" --format=d --verbose "C:/tempDB/restore.sql" – user182824 Jun 10 at 16:48
  • @user182824 it looks like you still need to update the path to the binaries in Preferences, which is the important bit – Peter Vandivier Jun 10 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.