1

I installed SQL Server 2017 Enterprise (14.0.3162.1) on my box. With the polybase (Scale-out Group). But when I try to enable through:

exec sp_configure @configname = 'polybase enabled', @configvalue = 1;
RECONFIGURE WITH OVERRIDE; 

It shows:

Msg 15123, Level 16, State 1, Procedure sp_configure, Line 62 [Batch Start Line 0]
The configuration option 'polybase enabled' does not exist, or it may be an advanced option.

So I used:

sp_configure 'show advanced option', 1;
GO
RECONFIGURE
Go

and check by:

select * from sys.configurations where name like '%poly%'

only:

polybase network encryption
allow polybase export

shows up.

How can I enable this feature in this case?

Please let me know if I missed any.

2
1

SQL 2017 is not good with Polybase. Currently, I am using SQL 2019 for this and all is good.

0
exec sp_configure @configname = 'allow polybase export', @configvalue = 1;
RECONFIGURE;
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.