0

I'm new to Oracle, so please bear with me.

I recently installed Oracle XE Release 11.2 on a Windows 2008 Server that we have. The installation was successful. During installation, I was asked to set a password for sys, and I did that. Also, the HTTP port used was 8085.

So now I'm trying to create a new database. I have Toad Data Point, but I'm not sure how to connect to the server or how to create the database.

In a browser, I went to http://OurServer:8085/ but it asks for password. I tried logging in with sys, but it doesn't let me. I also tried logging in using my company userid (the one I use to log on to my Windows PC), but it didn't work either.

What else can I do?

2

Oracle 11 does not use containers so you already have a database and the default users such as sys and system and all the other oracle built in users.

Go to Computer Management/Local Users and Groups and verify that the group ora_dba exists. Assuming this is a development project add your regular windows username to the ora_dba group. Now you can log on as sysdba using these steps:

  • open a command window
  • enter SET ORACLE_SID=XE
  • enter sqlplus / as sysdba

This should get you logged on as sys which you should not do normally. For this one time create a user and grant them a role.

CREATE USER < your new user name > IDENTIFIED BY < your new password >;
GRANT DBA to < your new user name>;

Then enter exit to close the session. Log on as your new user using Toad and you should be good to go.

I note that the operating system and database are out of support and you would be better off using the new 18xe on linux.

  • The problem is that I don't know the name of the database since I haven't created one yet. How can I set ORACLE_SID without the name? – rbhat Jun 12 at 14:34
  • @rbhat You do have an Oracle instance which is called XE. That is the hard coded SID for the version you are using – kevinsky Jun 12 at 14:41
  • The SID for XE can only be XE. – Michael Kutz Jun 12 at 14:48
  • I'm not sure what I'm doing wrong then. This is the screenshot of the connection manager in Toad: i.stack.imgur.com/V52WD.png. I get error ORA-03113: end-of-file on communication channel – rbhat Jun 12 at 15:33
  • 1
    Thanks again. I wasn't aware I had to use the listener port. I was always typing in the HTTP port. – rbhat Jun 12 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.