1

I have a redmine postgresql folder backup (no dump) from postgresql 9.4 and want to move it to a new server with debian 10 (buster) with postgres 11.

On my debian buster server I tried to get this old database running, so I installed the old postgresql-9.4 there with this tutorial: https://wiki.postgresql.org/wiki/Apt#Quickstart

When I tried to start the old cluster it said:

$ pg_createcluster 9.4 main --start
Configuring already existing cluster (configuration: /etc/postgresql/9.4/main, data: /var/lib/postgresql/9.4/main, owner: 117:120)
Error: move_conffile: required configuration file /var/lib/postgresql/9.4/main/postgresql.conf does not exist

I managed to start a new cluster2 with this instruction: https://stackoverflow.com/a/48624460/1069083

But that one is empty. My old main cluster contains all my data.

How do I start the old main cluster?

1

I solved it like this:

  1. I had to restore the old config too in

    /etc/postgresql/9.4/main
    
  2. Then I could start the old main cluster with

    pg_ctlcluster 9.4 main start
    
  3. Then I had to update redmine:

    cd /usr/share/redmine
    

    and start

    bundle exec rake db:migrate RAILS_ENV=production
    
  4. check if redmine is working correctly in your browser, Now you can upgrade postgresql to 11. first dump the database with

    sudo -u postgres pg_dumpall > /root/full_dump.sql  
    
  5. remove postgres 9.4 and install postgres 11, then

    sudo -u postgres psql -d postgres < /root/full_dump.sql
    /etc/init.d/postgresql restart
    
  6. check /var/log/redmine/default/production.log for any errors, for example check in /etc/redmine/default/database.yml if redmine is still trying to connect on port 5433

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.