0

I'm trying to use ASMCMD but it doesn't return any result in the command line

ASMCMD> ls
ASMCMD>
ASMCMD>
ASMCMD>
ASMCMD> lsdg
ASMCMD>
ASMCMD> pwd
ASMCMD>

The version of database is 19c, the only environment about oracle grid is the GRID_HOME, but I also have the ORACLE_HOME and ORACLE_BASE, currently my $ORACLE_SID is orcl and my $ORACLE_HOME is /u01/app/oracle/product/19.3.0/dbhome_1.

My output about srvctl config asm is:

ASM home: <CRS home>
Password file: +DATA/orapwasm
Backup of Password file:
ASM listener: LISTENER,LISTENER2
Spfile: +DATA/ASM/ASMPARAMETERFILE/registry.253.1011650339
ASM diskgroup discovery string: /dev/oracleasm/disks/*
1

Incorrect environment. ORACLE_HOME for grid should be pointing to grid directory and ORACLE_SID for ASM should be +ASM.

Try this:

export ORACLE_HOME=$GRID_HOME
export $ORACLE_SID=+ASM
export PATH=$GRID_HOME/bin:$PATH

Kumar

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.