0

I want to install Oracle JDeveloper on my Ubuntu 18.04, and I have downloaded the installer file from here, there I download the file1 and file2 to Linux.

Here is the file name for file1, and the size is 2,0 GB:

jdev_suite_122130_linux64.bin?AuthParam=1561523342_6bfe09585a7e74ebd661dfe1d3d49427

And here is file name for file2, and the size is 432,1 MB:

jdev_suite_122130_linux64-2.zip?AuthParam=1561523346_b29a360806455b82e4a0db9e4e7767b9

I have tried to follow many tutorials how to install the JDeveloper, here is one of example tutorial that I try to follow.

There.., after I got the installer file, we should give permission access using this command:

sudo chmod +x jdev_suite*.bin

I ran the command to the file1 and file2, and here is permission:

harvest# ls -l jdev_suite_122130_linux64.bin\?AuthParam=1561523342_6bfe09585a7e74ebd661dfe1d3d49427 
-rwxr-xr-x 1 tri tri 2045438518 Agu 26  2017 'jdev_suite_122130_linux64.bin?AuthParam=1561523342_6bfe09585a7e74ebd661dfe1d3d49427'
harvest# ls -l jdev_suite_122130_linux64-2.zip\?AuthParam=1561523346_b29a360806455b82e4a0db9e4e7767b9
-rwxr-xr-x 1 tri tri 432104829 Agu 26  2017 'jdev_suite_122130_linux64-2.zip?AuthParam=1561523346_b29a360806455b82e4a0db9e4e7767b9'

Then I start the installation using this command:

./jdev_suite_122130_linux64.bin?AuthParam=1561523342_6bfe09585a7e74ebd661dfe1d3d49427

I tried that command on normal user and also try as root, but I got this message after that:

Launcher log file is /tmp/OraInstall2019-06-26_02-04-26PM/launcher2019-06-26_02-04-26PM.log.
Extracting the installer . . . Done
Self extraction to /tmp/sfx_i5T36W failed.
The log is located here: /tmp/OraInstall2019-06-26_02-04-26PM/launcher2019-06-26_02-04-26PM.log.
ERROR: Installer execution failed (1).

After I looking at the log base on that message, here is the log:

harvest# cat /tmp/OraInstall2019-06-26_02-04-26PM/launcher2019-06-26_02-04-26PM.log
2019-06-26 14:04:26,534 INFO  [1] com.oracle.cie.nextgen.launcher.LogUtils - Launcher log file is /tmp/OraInstall2019-06-26_02-04-26PM/launcher2019-06-26_02-04-26PM.log.
2019-06-26 14:04:26,544 INFO  [1] com.oracle.cie.nextgen.launcher.LogUtils - Extracting the installer . . .
2019-06-26 14:04:26,545 SEVERE [1] com.oracle.cie.nextgen.launcher.Launcher - 
The jar file /home/tri/Downloads/oracle/jdeveloper_12c/jdev_suite_122130_linux64.bin?AuthParam=1561523342_6bfe09585a7e74ebd661dfe1d3d4-2.zip needed for this installer is missing.
2019-06-26 14:04:26,547 SEVERE [1] com.oracle.cie.nextgen.launcher.Launcher - Self extraction to /tmp/sfx_i5T36W failed.
2019-06-26 14:04:26,547 INFO  [1] com.oracle.cie.nextgen.launcher.LogUtils - The log is located here: /tmp/OraInstall2019-06-26_02-04-26PM/launcher2019-06-26_02-04-26PM.log.

I have tried to follow this instruction to Download both File1 and File2 and place it in the same directory, but still doesn't work.

So, please help me with this.

2

I resolved this following Kumar's comment:

I fired up fresh Ubuntu 18.0.4 virtual box installed open jdk 8 and Oracle JDeveloper without any errors. From log files it looks like self extraction is failing something to do with parameter AuthParam and what exactly is that? What happens if you try without Authparam?

Just remove the AuthParam on that file. Just Like this:

before:

jdev_suite_122130_linux64.bin?AuthParam=1561523342_6bfe09585a7e74ebd661dfe1d3d49427

after:

jdev_suite_122130_linux64.bin

And then install that as a usual way:

./jdev_suite_122130_linux64.bin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.