0

Maybe that's a wrong form of answer... The problem is:

I've got an Oracle database dump file (very old, created with imp utility) At last, I've imported it. The command was imp file=E:\Downloads\db_dispatcher\disp.dmp full=y The console shows me there was success. enter image description here Now when I open my Oracle SQL developer and create any connection, I can't list my database (there must be at least one): in 'tables' section I only see this system stuff.

enter image description here

I the DB name should be 'meltshop', so I tried to find it in my Windows Services list. But there's none.

Oracle SQL developer 19, Windows 10. DB was created in 2009.

I am a newbie with Oracle( The last year I worked with MySql database. Maybe here are any similarities? I also have php interface; the config shows me

$DBNAME = "<ip>/orcl.meltshop";
$DBLOGIN = "ml2_rt";

Instance, version, etc.:

select instance_name, host_name, version from v$instance;

INSTANCE_NAME
----------------
HOST_NAME
----------------------------------------------------------------
VERSION
-----------------
xe
DESKTOP-T6U2873
11.2.0.2.0

The log of my last try: google disk

2
  • Post full command used for imp. I'd like to see more of what was imported. Please re-make your first screen shot so that shows as much output as possible. Jun 26, 2019 at 13:32
  • @MichaelKutz, thanks for your support, but 2GB DB import with full=Y... I'll try to remake the imp Jun 26, 2019 at 13:33

1 Answer 1

0

SQL Developer shows you the objects of the user you connect as. It looks like you are connected as SYS or other high privilege user. Way, way at the bottom of the file tree on the left is the "Other Users" icon.

Click on this and all the database users (or schemas) will be shown. If "meltshop" is a user they will be listed there.

Now that you have provided more details I see that the user name is ML2_RT. This schema has been imported into the SYSTEM user which is unfortunate as this should not be used for user data. You should try this which points the data to a user

CREATE USER ML2_RT identified by "aPassword" DEFAULT TABLESPACE USERS;
GRANT CONNECT, unlimited tablespace TO ML2_RT;
then reimport again

imp database name/password@XE file=<your file path and dump file name>  
  fromuser=ML2_RT touser=ML2_RT

Also you seem to have some errors with the character set due to the import having a different character set. That will be harder to solve.

7
  • So I need to create a USER meltshop first? Jun 26, 2019 at 13:30
  • the log is there Jun 26, 2019 at 13:51
  • @VictorGorban Please post the log as firewall prevents me from clicking on .ru links
    – kevinskio
    Jun 26, 2019 at 14:05
  • I'll post it as google disk link. @kevinsky, posted Jun 26, 2019 at 14:08
  • My firewall blocks mist downloads. Jun 26, 2019 at 14:28

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .