-1

I did raid reconfiguration of SQL Server 2016 box. All my systems databases files (mdf and ldf) are in D drive and SQL Server installation also is in D drive and i have them intact. I have lost user databases and i have backup of all those.

But after raid reconfiguration,i tried to start the SQL Server(MSSQLSERVER),SQL Server Lauchpad and SQL Server Agent. Only Agent starts and SQL Server(MSSQLSERVER) starts are then stops. SQL Server Launchpad gives an error when i start with error message "The request failed or the service did not respond in a timely fashion.Consult the event log or other applicable error log for details".

I dont need the lauchpad,but i need SQL Server service to start.

Any idea why the service is not starting.? I am using NetworkService and i chnaged it to LocalSystem and tried ,but i get error.So i have it back to NetworkSerive again.

1

You need to check the file named errorlog for details to why it failed.

Possibilities are that it cannot find the files for the master database (pointed out from the registry) or that it can find master files, but some of the other system databases databases files (as pointed out from the master databases) aren't in the right place.

Possibly it can't create tempdb where you have specified it to be created.

Tibor Karaszi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.