1

This question already has an answer here:

I have created an Active Directory Group and created it as a user, we'll call it "AD SQL", in my DB. I can successfully login in using Active Directory Authentication and read/write.

However, Intellisense is not working for any Active Directory users.

If I log in using my Active Directory Admin, "AD ADMIN", Intellisense works fine.

Can anyone tell me what permissions/roles/view/etc are needed for a user to have access to Intellisense?

My "AD SQL" user the following roles/permissions:

  • db_owner
  • db_datareader
  • db_datawriter
  • GRANT CONNECT (DATABASE)
  • GRANT VIEW DEFINITION (DATABASE)

And I have already tried Refreshing Cache/Restarting SSMS.

marked as duplicate by Josh Darnell, Marcello Miorelli, mustaccio, kevinsky, Gaius Jul 11 at 14:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • After you grant db_owner to use, you don't need to grant rest of the permissions you mentioned. – Rajesh Ranjan Jul 10 at 6:12
  • Make sure you didn't DENY something from AD SQL. From my experience, intellisense should work "with the basics". I just tried that with only db_datareader and it worked fine. My guess is that DENY of something essential was done either directly to AD USER or to some other windows login for a windows group that the person is a member of. – Tibor Karaszi Jul 10 at 8:18
  • And make sure that intellisense is enabled. Refreshing intellisense will not automatically enable it if it is disabled. – Randi Vertongen Jul 10 at 8:32
  • Have you installed any third party add-ins for SSMS like Apex and Redgate? Sometime it causes problems. I faced similar issue which fixed post installation of the add-ins. – Rajesh Ranjan Jul 10 at 10:06