0

I've installed SSDT and while tring to browse the cube I get this error enter image description here

Here it tries to connect to port 2383 which is for the default instance, but in my case SSAS is installed for a named server under port 2382. How to correct this error, so the system could understand that this is a named server?

everything is installed locally, and port 2382 is open, firewall is turned off. Should I change the port number in Visual Studio?

Thanks

0

It would be helpful to know if your running in a Clustered environment or not. However here are some suggestions:

1) Make sure that SQL Browser service is running and that the service user has local administrator rights (Local System Account). Please note that SQL Browser service listens for client requests on port 2382 and then redirects the client connection to the port used by SSAS instance. (In your case it would be 2383)

2) If Analysis Services is running on a Windows Server Failover Cluster (WSFC), the SQL Browser service has to be started on all of the nodes of the WSFC

3) The port information for the instance is relayed by the SQL Browser services only if property InstanceVisible is set to 1 (true). Verify this under General / Advanced settings of SSAS.

4) Test for connectivity by using the telnet command:

TELNET InstanceName PORT

If you get a "Could not open a connection to the host, on port" error message, it could mean that the instance is running on a different port or something is blocking access to this port.

  • Thanks for the answer. There is no cluster. Just in my local computer I have SQL Server and in the same host SSAS is installed. with telnet port 2382 is open, 2383 not @TahirRiaz – igelr Jul 11 at 11:53
  • Run the following commands to find PID (Process ID) : " tasklist | findstr msmdsrv.exe " Run netstat to find all ports SSAS is listening to: " netstat -nao | findstr [PID]" Also make sure that you only use Instance name + port when you are connecting. – Tahir Riaz Jul 12 at 9:11
  • Port 2383 is for the default, that's why no one is listening there. As a named server it listens to port 2382. How to specify the front end app to connect to the required port? I've done netstat and staff, I know the problem, just can't find the solution. @TahirRiaz thanks – igelr Jul 12 at 12:56
  • What are you using to connect? – Tahir Riaz Jul 12 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.