0

I have a stored Proc that runs a DBCC command CHECKIDENT The sproc is being run by a user with adequate permissions. however, it is failing on the DBCC command with the error.

User 'DifferentUser' does not have permission to run DBCC CHECKIDENT for object

I cannot figure out how this user is the one being used I have even removed this DifferentUser from the instance and all of the databases.

I am in a quandary

  • 1
    Please provide the Stored Procedure definition. – John Eisbrener Jul 19 at 15:43
  • Did you tried executing it without SP DBCC CHECKDB(DBName)? – Rajesh Ranjan Jul 19 at 17:34
  • I am unable to provide the entire stored proc. This is what I can provide The sproc is run as the highest elevated RDS Admin account possible. The Sproc creates a temp table and then has DBCC CHECKIDENT for the identity then fails saying some obscure user doesn't have permissions. The user account has been completely removed from the instance but it is still giving the same error. I have run the process as a sproc and as just a sql statement. – Swoozie Jul 21 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.