0

Linked Server SS 2012(SP4) to SS 2016(SP1) just stopped working. It times out with the error "Server is not found or not accessible". However I can connect and query the target server successfully with SSMS. How can SSMS work yet Linked Server cannot even "see" the target server?

  • How is the linked server mapping the credentials? Are they still present and working correctly on server 1. If the user on server 1 maps to a different user on server 2 can you log into server 2 using those same credentials? – KevH Jul 25 at 23:26
  • KevH, I am using the same credentials in Object Explorer which is working. The logins work if I connect via a query window, but the Linked Server cannot even "see" the target server. – Andy Jul 26 at 13:54
  • 2
    Any recent changes to firewall settings? Any DNS entry changes? Have you performed an ipconfig /flushdns command from the server having issues connecting to the linked server? – John Eisbrener Jul 26 at 15:33
  • John, Thank you for your comment. While crafting a response I realized that SSMS was connecting from my local machine (successful) while the linked server was connecting from Server A (un-successful). Now I understand the issue and know where to look. Thanks! – Andy Jul 29 at 16:40
0

There is an connection issue between Server A and B, NOT local machine and Server B.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.