0

This is a very strange bug. I'm using this on a mac:

mysql Ver 15.1 Distrib 10.4.6-MariaDB, for osx10.13 (x86_64)

If I import an SQL dump of a WordPress DB (so not very complicated structure, but some long lines) from the command line, the table structure for all tables appears normal, but lots of content is missing from InnoDB tables.

Specifically, where the INSERTS have been 'chunked' into groups of records, only the final group is there. If I use --skip-extended-insert to write a statement for every record, only one record is ever in the InnoDB table.

MyISAM data seems fine. Using MySQL 8.0.16 is fine, it's MariaDB that isn't.

(I've tried dropping and recreating the database).

Note: I had very similar, possibly identical, problem with Drupal on MariaDB recently when clearing the cache - which rebuilds the router table, but many rows were missing.

  • Have you tried it on an older version? – Rick James Jul 28 at 19:30
  • @RickJames it's installed with homebrew, so I can't easily roll back to a previous version. I've just switched from mariadb back to mysql (Ver 8.0.16 for osx10.13 on x86_64 (Homebrew)) and that's ok. I had a very similar problem with Drupal recently so maybe I need to be reporting this somewhere… – William Turrell Jul 28 at 21:03
  • 3
    You can report it here: jira.mariadb.org/projects/MDEV – dbdemon Jul 28 at 21:19
  • @dbdemon - Thank you - finally got around to filing a bug for this - in the meantime I also noticed it only happens if you lock the table for writes first. There's also a Drupal issue here – William Turrell Aug 15 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.