We are using a AWS-RDS(MySQL 5.7) instance with 16GB RAM. We have a table with millions of entries and a FULL-TEXT index which needs to be OPTIMIZED.

Apparently, FULL-TEXT optimization is very expensive and hence MySQL provides the variable innodb_ft_num_word_optimize to control the number of words that is optimized at one time. The default value of this variable is 2000.

For some unknown reason we are not able to update this value beyond 10000. Increasing beyond this results in the RDS instance being stuck in Incompatible-parameter state. In one of the other RDS instance, changing the value did not produce any error but the value of innodb_ft_num_word_optimize maxed out at 10000. MySQL documentation does not mention any max value for this variable.

Can someone explain this behavior ?

  • Suggest providing a bug to bugs.mysql.com . – Rick James Jul 31 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.