0

I had two node cluster but due to disk corruption one node was removed. After maintenance when second node came back we tried to add it into the cluster but getting exception.
I checked the even log for "Failover Cluster Manager\diagnosis" path and found below exception:-

Exception occurred in background operation - System.ApplicationException: An error occurred while adding nodes to the cluster 'Cluster_name'. ---> System.ApplicationException: An error occurred while adding node 'node_name' to cluster 'Cluster_name'. ---> System.ComponentModel.Win32Exception: The parameter is incorrect --- End of inner exception stack trace --- at MS.Internal.ServerClusters.ClusApiExceptionFactory.CreateAndThrow(Cluster cluster, Int32 sc, String format, Object arg0, Object arg1) at MS.Internal.ServerClusters.Cluster.AddNode(String nodeName, ClusterActionCallback callback) at MS.Internal.ServerClusters.Configuration.AddNodeManagement.AddNodes(ActionArgs actionArgs, ActionUpdateHelper updateHelper) --- End of inner exception stack trace --- at MS.Internal.ServerClusters.Configuration.AddNodeManagement.AddNodes(ActionArgs actionArgs, ActionUpdateHelper updateHelper) at MS.Internal.ServerClusters.Configuration.AddNodeManagement.PerformAddNodes(ActionArgs actionArgs) at MS.Internal.ServerClusters.Configuration.ConfigurationBase.PerformActionWrapper(BackgroundOperationStatus backgroundOperationStatus, BackgroundOperationArgs parameter) at MS.Internal.ServerClusters.BackgroundOperation`2.BackgroundOperationProc(Object state)

Please help me out from this issue.

  • This would probably be better on [ServerFault](www.serverfault.com) – George.Palacios Jul 30 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.