1

I have just done a clean install of SQL Server 2017 (CU15) on two of my servers, and have noticed that the displayed language for all my logins shows ARABIC instead of '' or 'English'.

Here is the server settings

enter image description here

Here is a login setting

enter image description here

When I run the following SQL code, I get 'us_english' for the default_language_name:

SELECT type_desc,
        default_database_name,
        default_language_name,
FROM master.sys.server_principals
WHERE name = 'Cerberus'

| type_desc        | default_database_name    | default_language_name |
+------------------+--------------------------+-----------------------+
| WINDOWS_LOGIN    | master                   | us_english            |

Did I mess something up on installation? How do I correct this?

  • Is it possible that someone was on this dialog and hit the a key accidentally, didn’t notice, and hit OK? – Aaron Bertrand Aug 6 '19 at 0:46
  • @AaronBertrand The second server was installed via the config file produced after the first server was manually installed, and I was the only person in front of either installation for the entire duration.. – Kulstad Aug 6 '19 at 11:35
  • I don't know, SQL Server took that setting from somewhere. Did you check in AD (or ask your domain admins)? – Aaron Bertrand Aug 6 '19 at 12:16
  • I've checked the Region setting on each server's OS, and the both read ENGLISH (Canada). The same SQL account on my PROD server (same domain, same AD, different SQL CU (PROD is at CU12)) reads English for default language. – Kulstad Aug 6 '19 at 15:42
  • I have the exact same issue. I did a clean install of sql and all the accounts is set to arabic as default language even though there isn't a single setting anywhere that is close to being arabic. The server is set to English, all the instances is set to English, SSMS is set to English and so forth. I tried to install a new instance on the same server but the issue persists. If i try to change the default language to English manually it resets after the SSMS is restarted. Which settings have I missed here? – Timmy Aug 27 '19 at 11:24
2

This bug has been fixed as of SSMS version 18.3.

| improve this answer | |
  • Thank you! I have been pulling my hair out today of over an hour! – Mark Kram Mar 17 at 0:06
1

You can just change it for those two logins to whatever you want them to be by hitting the dropdown arrow for default language. It could be pulling from windows account preferences would be my guess since its a windows account.

| improve this answer | |
1

Finally found that there's a bug with SSMS 18.2 that creates this issue. Install another version of SSMS or connect from another server / computer it will show the correct settings.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.