1

We have been using Aurora serverless databases in staging and production environments for a few months now, and find the CPU remains in the range 15-20% almost all the time. However in the past week the CPU utilisation has been growing, even during periods of zero load and is now at 38%. I'm worried this trend will continue further and begin to become an issue.

I saw the same trend in our Staging environment, but it only lasted 3 days and then returned to the usual level.

What could be driving this and how should I be debugging and resolving the root cause(s)?

Chart from AWS database monitoring

SHOW FULL PROCESSLIST

Returns only 6 rows.

Results from SHOW FULL PROCESSLIST

----- Update 4th Sept 2019 -----

In the end, I just continued to monitor it, and once it reached 50% it dropped back down. I guess it is a quirk of Aurora serverless? Would be great to hear from anyone else facing this issue as I hate not understanding things.

enter image description here

  • Use SHOW FULL PROCESSLIST to see what is running. Use the "slowlog" to see what queries are taking a lot of time. Meanwhile, I see that the "drop" occurs about midnight every night -- when Amazon do backups (or whatever)? – Rick James Aug 8 at 22:16
  • @RickJames I added the results of SHOW FULL PROCESSLIST to the question. – Phil192 Aug 12 at 8:21
  • Try again, or use the slowlog. – Rick James Aug 12 at 15:13
1

What solved it for me was setting the min and max instance count higher than before (forcing aurora to scale up, for example from min 2 ACU to min 4 ACU), and after scaling restoring the scaling settings.

I used 'Force scaling the capacity to the specified values when the timeout is reached' and 'Apply immediately'.

It also solved another issue we had, the 'Serverless database capacity' indicated 4 ACU while it was actually 2 ACU (as seen in the picture)

we expect 45% cpu with 2 instances, not 80%

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.