25

Every query I run in SSMS append the annoying message: "Completion time:...".

How can I disable that text?

0
17

In SSMS 18.3, they added the option to turn off the completion time.

Tools > Options > Query Execution > SQL Server > Advanced.

Uncheck the Show Completion Time checkbox.

Start a new query window and execute something... No completion time after query finishes. Yay!

0
16

The completion time message was added in SSMS 18.2

https://cloudblogs.microsoft.com/sqlserver/2019/07/25/sql-server-management-studio-18-2-is-now-generally-available/

I don't believe there is a way to turn it off

0
0

This a 2 step process.

1)Tools > Options > Query Execution > SQL Server > Advanced - Uncheck: Display Execution Time

2)Close the query window and open an new one. If you don't do this it will always show. This drove me nuts as I had a long proc and I could not get it to stop until I closed and re-opened.

1
  • 1
    Isn't this saying the same as the accepted answer from two years back?
    – mustaccio
    Jul 19 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy