I am trying to install the new version of the mysql on the windows7 and windows xp . In few of the computers already a new version of mysql are installed. Here I just want to create a second instance of the service of mysqld with my my_XX.ini file.

I have successfully configured the instance on the windows 7 pc . But can not create instance on the windows xp for the same .

I am trying this code on the command prompt which run as administrator. but it does not start the service

sc create mysqld2 binPath= c:\mysql\bin\mysqld.exe --defaults-file=c:\mysql\my_XX.ini

Even I have tried with the mysqld command to start the mysql as per other my_xx.ini with

mysqld --defaults-file=c:\mysql\my_XX.ini 

I am not able to create a second instance on the windows xp . Please help me to start the second instance of mysql on windows xp with windows service

  • try using mysqld --console --defaults-file... to see what error is coming and why service cant be started
    – jsist
    Commented Sep 19, 2012 at 5:03
  • Its saying plugin 'FADERATED' is disabled . But it would be better to create service like sc create so that i can connect to application.
    – hbdev ror
    Commented Sep 19, 2012 at 5:12
  • even if you are doing through sc use --console to see what is happening and error messages
    – jsist
    Commented Sep 19, 2012 at 5:14
  • Please provide command for that . Is it sc create binPath= "c:/Mysql/bin/mysqld.exe --console --defaults-file=c:\mysql\my_xx.ini or sc create --console binPath= "c:/Mysql/bin/mysqld.exe --defaults-file=c:\mysql\my_xx.ini
    – hbdev ror
    Commented Sep 19, 2012 at 5:20

1 Answer 1


=> only set my_ibt.ini in the pateh C:\RailsInstaller\ => my_xxx.ini

#if already installed then use that basedir
basedir = "C:\RailsInstaller\MYSQL"

#where you want to set your database
port = 43307
socket = mypipe1

In the command promt which runs as administrator go to
\MYSQL\bin> And run Command :

mysqld --install mysqld_xxx --defaults-file=C:\RailsInstaller\my_xxx.ini

Service successfully installed.

Then :

net start mysqld_xxx

The mysqld_ibt service is starting. The mysqld_ibt service was started successfully.

  • I have solved the issue by own which works for both windows xp and windows 7 equally
    – hbdev ror
    Commented Sep 29, 2012 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.