I have newly installed following things on my system

     - Microsoft SQL Server Management Studio 2014 
     - SQL Server 2017
     - Visual Studio 2015

When I tried to open SSMS for the first time, it asked me for the "Server Name" when I surfed I came to know that I have to check the instance name in Configuration manager-->Sql Services, but I couldn't find any services running in Configuration Manager, it is showing "There are no items to show"

Secondly, I also tried giving the permissions to my SQL Server services as mentioned in article here, but couldn't solve my issue.

Also I tried to check find the SQL Server instance name using the sqlcmd -L command, but it didn't show any servers, even though SQL Server is already installed.

What am I doing wrong?

enter image description here No Server Server Instance Found although Server is installed enter image description here enter image description here

  • i am not an expert here but I would try the two values that you found. It seems it should either be DMRDBILCND7288L or it should be SQLEXPRESS Aug 15, 2019 at 17:44
  • 1
    If the SQL Server Configuration Manager doesn't display any services, see that you have started the right version. The file name is SQLServerManager<version>.msc and should be in \Windows\System32 dir. There might be several, so pick the latest.
    – vonPryz
    Aug 15, 2019 at 18:12
  • You should also use a way more recent SSMS version if you're on SQL Server 2017 Aug 15, 2019 at 19:18

1 Answer 1


SQLExpress is installed as a named instance. Try connecting to <server name>\SQLEXPRESS

Or localhost\SQLEXPRESS will work as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.