4

Need to apply a Service Pack to the following SQL Express install:

Installed version : 12.0.2000.8 (2014) Express Edition

Not sure if I can apply the latest SQL 2014 Service Pack SP4 or stick to the latest Express Service Pack I have found SP3.

Are service packs for SQL 2014 different than the service packs for SQL 2014 Express?

  • Randi, thank you for answering my question!.... and you are correct there is no SP4, I should have said SP3 CU4. – Peter Aug 22 at 11:28
7

Are service packs for SQL 2014 different than the service packs for SQL 2014 Express?

There is no difference in service packs or cumulative updates between SQL Server Express edition and other editions such as developer, standard or enterprise.

When looking at the latest build of sql server 2014, SP3 CU4 is the last one with build number: 12.0.6329.1 (Latest build). I'm not sure where SP4 is coming from?

When looking at the applies to field from SP3 CU4:

Applies to: SQL Server 2014 Developer SQL Server 2014 Enterprise SQL Server 2014 Enterprise Core SQL Server 2014 Standard SQL Server 2014 Business Intelligence SQL Server 2014 Express SQL Server 2014 Web

You will find SQL Server 2014 Express

Download SP3 CU4 here

Remember that you would have to apply the service pack first, and then add the CU. A list of sql server (2014) build versions can be found here, here and an overview of all the recent updates here .


EDIT

...I get the impression that I need to update to SP3 1st THEN apply the CU4 patch. Since I'm starting with the base version of SQL Express (SP1 or SP2 not applied), can I just skip right to installing SP3 and then CU4 or do I first need to apply SP1 and SP2?

Since Service packs are cumulative you can directly install SP3 while skipping SP1 and SP2 and then install CU4.

Also If I were to download SP3, I have a number of choices of files to download. Not sure which to pick. See options from this link: microsoft.com/en-us/download/details.aspx?id=57473 Appreciate any additional guidance you can provide...

The link provided is to download sql server express / local db / express with tools / express advanced edition with the SP3 installed when you don't have express installed.

You should download the regular SP3 patch, without express.

If you follow this link, you will see these two options:

enter image description here

Click on the one without express, SQL Server 2014 SP3

The ones with express are complete instances of sql server with the patch added.

Just to show you that I am not making this up, when scrolling down on the patch notes of SP3, go to the part: "Select the correct file to download and install"

enter image description here

Only install this one if you have no 64-bit version of SQL Server 2014 Express.

And for the correct file: (I think SP2 is a mistake, supposed to be SP3)

enter image description here

A patch for any Edition, express included. The Service pack you need, SP3 is this one .

Afterwards, download and install CU4 for SP3 from here

  • Hi Randi, sorry to bother you again. Based on your comments and additional research I get the impression that I need to update to SP3 1st THEN apply the CU4 patch. Since I'm starting with the base version of SQL Express (SP1 or SP2 not applied), can I just skip right to installing SP3 and then CU4 or do I first need to apply SP1 and SP2? Also If I were to download SP3, I have a number of choices of files to download. Not sure which to pick. See options from this link: microsoft.com/en-us/download/details.aspx?id=57473 Appreciate any additional guidance you can provide... – Peter Aug 22 at 12:11
  • @Peter No need to say sorry, we are on this site to help! Totally not bothering me! I will add it to the answer right away! – Randi Vertongen Aug 22 at 12:24
  • @Peter I do get your confusion with the SP3 Express patches, these come with an express instance themselves. I added everything relevant to the answer, let me know if I need to clear antything up :) – Randi Vertongen Aug 22 at 12:39
  • Hi Randi, Just checking my posting at the end of today. I wasn't expecting such a quick response! Your advice/knowledge saved me some major pain. Your advice is spot on. Thanks for all the links. Especially the link to patch notes of SP3. I definitely don't want to install a new instance of SQL Express!...just SP3 (and CU4). Just need to reconfirm whether the PC is running the 32bit or 64bit edition, then I'll be good to go. Feel way more comfortable that I'm installing the correct patches now. Thanks for all your guidance! – Peter Aug 22 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.