1

My application is running in Azure SQL which doesn't support DTC. We only use Azure SQL in upper environments. In the local development environments, we're still using SQL Server 2016.

I want to avoid a situation, which has happened a couple of times in past where a developer has ended up writing queries with a transaction that ended up escalating to DTC, which of course was only caught in upper environments.

I'm looking for a command to run in SQL Server to completely remove its ability to participate in DTC, basically make it like its Azure SQL counterpart.

Edit: I don't want to remove MSDTC from the system itself as I've other services, that doesn't involve Database, that requires MSDTC.

  • Have you tried disabling the Distributed Transaction Coordinator service via the services.msc MMC snap-in? – John Eisbrener Aug 23 at 13:49
  • 1
    Keep in mind that Azure SQL is a different product with a different engine that is on a 100% different release cycle than SQL Server - you're bound to encounter more issues like this as time goes on. – LowlyDBA Aug 23 at 13:58
  • are these linked server queries? if so, you could try setting "remote proc transaction promotion" on the linked server definition to false – Bob Klimes Aug 23 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.