1

From what I can understand/read it should suffice to have the filesystem as XFS and the dbpath set to a folder on that disk. What else do I need to do to fix this? I moved the whole db folder from the initialized ext4 folder it was mounted on in the template. Is there a lock file I need to clear or something so that it re-checks the filesystem rather than thinking it's the old ext4 ?

Log

Server has startup warnings:
2019-08-28T08:34:56.863+0000 I STORAGE  [initandlisten]
2019-08-28T08:34:56.863+0000 I STORAGE  [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
2019-08-28T08:34:56.863+0000 I STORAGE  [initandlisten] **          See http://dochub.mongodb.org/core/prodnotes-filesystem

However....

parted -l

Model: Msft Virtual Disk (scsi)
Disk /dev/sdc: 275GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:
Number  Start   End    Size   Type     File system  Flags
 1      1049kB  275GB  275GB  primary  xfs

/etc/fstab

UUID=cdf895f5-190c-422a-b9a5-e8ba4cfad807       /        ext4   defaults,discard        0 0
UUID=567781bc-8045-4e0d-a4f9-a971b671e920       /data    xfs   defaults,nofail,noatime         1 2

mongodb.conf

# Where to store the data.
dbpath=/data/mongodb/data/db

#where to log
logpath=/data/mongodb/log/mongodb.log

logappend=true

# Enable journaling, http://www.mongodb.org/display/DOCS/Journaling
journal=true
  • This startup message is only a warning, so you can ignore it if isn't relevant. What specific version of MongoDB server are you running? The journal config comment includes a suspiciously old docs link. – Stennie Aug 29 at 10:12
  • Iirc it was 3.2. Its based on the mongodb bitnami template in Azure marketplace. – user4370259 Aug 30 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.