0

I cannot patch the latest CU4 for SQL 2014 SP3. Checked "view installed program", 4500181 is already installed.

enter image description here

but when I use "Select @@version" against my SQL instance, it still shows "12.0.6259.0" which is SP3-CU3. Has anyone encountered this before and how to fix it?

Thanks,

7
  • what error do you get ?
    – Kin Shah
    Aug 28 '19 at 14:01
  • Once I try to patch CU4. This message shows up: The version of SQL Server instance MSSQLSERVER does not match the version expected by the SQL Server update. The installed SQL Server product version is 12.0.2000.8, and the expected SQL Server version is 12.3.6024.0. Aug 28 '19 at 14:02
  • 1
    first patch with sp3 then with cu4 - since it tells the product version is 12.0.2000.8 - which is RTM.
    – Kin Shah
    Aug 28 '19 at 14:03
  • The build number is already 6259...which is already SP3-CU3 Aug 28 '19 at 14:07
  • 1
    What do your bootstrap log files show? These can generally be found in C:\Program Files\Microsoft SQL Server\120 and they should contain some more detailed error information. Aug 28 '19 at 14:30
4

I am not 100% sure this is the cause of your issue, but this is too long for a comment.

This can occur if SQL Server components are installed similar to the following:

  1. Install SQL Server Database Engine
  2. Install a service pack
  3. Install Reporting Services

At this point, the installer will refuse to install a post-SP CU due to the RTM version of Reporting Services. Based on my investigation, a certain registry value gets reset to the RTM version when Reporting Services is installed, and this is what the installer is referring to.

The solution is to install the service pack again (SP3, in your case), which will update Reporting Services, and then you will be able to install the post-SP3 CU.

I would assume this would be the case for other components such as Analysis Services, but I have only run into this issue with Reporting Services.

2
  • Thank you Tony, I fixed it with re-install SP3 on it. Aug 28 '19 at 17:22
  • This can also occur if you install other features after the SP - Like full text search.
    – Trubs
    Aug 25 '20 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.