0

Cross posting this question here, since I haven't gotten an answer there: https://superuser.com/questions/1476105/mysql-service-stuck-at-starting-after-increasing-innodb-log-file-size

Good day everyone, We are trying to install the 'ESET Enterprise Inspector' on a server, which requires mysql. we installed MySQL Server 8.0 in the requirement page it says we have to use these parameters:

requirement

But when we try to start the mysql service, the progress bar goes to end (for two minutes) and it says "the service did not respond to the start or control request in a timely fashion" and it is stuck in starting status. the eset installer doesn't continue to install if we haven't used those parameters. The server has 32G of ram and we use innodb_buffer_pool_size=26G and innodb_log_file_size=13G

Does anyone know why the service doesn't start? Here is the my.ini file. Thanks in advance.

1 Answer 1

1

I recommend you change back that setting.

The problem is that the old versions of MySQL did not have a way to change that setting without some extra manual effort, namely removing the log files.

Unless the setting was terribly small, the failure to change it won't impact performance much.

Hmmm... Are you upgrading from some old version to 8.0? If so, there are other steps.

Meanwhile,...

Increase the value of open_files_limit to at least 30000.

That seems very high, unless you expect to have thousands of tables, which is another problem to discuss.

Change the value of innodb_flush_log_at_trx_commit to 0.

There are 3 options for that variable; I wonder why they picked the worst.

1
  • The problem is, installer literally doesn't continue if we don't edit those parameters. and it's not an upgrade.
    – alireza
    Aug 29, 2019 at 6:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.