1

I am patching a SQL2008R2 Express Edition instance. On the first failed attempt, all seemed to be fine - SQL loaded, dbs online, @@VERSION returned the expected results, but errors were found during installation.

I had the issue below

The registry key System\CurrentControlSet\Services\MSSQLSERVER\Performance is missing.

For which I followed this post to fix

https://blog.sqlauthority.com/2018/04/28/sql-server-service-pack-failure-missingregistrykeyexception-the-registry-key-is-missing/

It seems to have worked. I ran Repair from the setup image. But I am not able to run the patch - the initial screen tells me that the Upgrade Status is 'Installed' - whereas before this Repair fix it told me 'Installation incomplete'.

Cannot run patch screen after Repair

Can anyone confirm that the patching has been successful? I would think so, as it says there SP3, Installed. @@VERSION returns the correct results, but it already did when the patch was 'incomplete'. Has SQL 'caught up' during the repair, or were the incorrectly installed aspects of SP3 repaired?

Thanks

3
  • extended support ended July 19, 2019. There are other newer express editions you can use such as SQL Server 2017 Express microsoft.com/en-us/download/details.aspx?id=55994
    – kevinskio
    Sep 4 '19 at 13:24
  • What do you mean
    – jack
    Sep 4 '19 at 14:25
  • 1
    I am suggesting that patching a database that is out of support is not doing the most useful work. Upgrading to a supported version is a good answer but out out of scope for your question
    – kevinskio
    Sep 4 '19 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.