0

I'm getting the following error:

Uncommitted changes pending for file MYTABLE in library MYLIB.

CPF325E

Cause . . . . . : Uncommitted changes are pending for file MYTABLE in library MYLIB for commitment definition MYTABLE.

Recovery . . . : Do one of the following and try your request again:

-- Complete the commitment control process by doing a commit or rollback for commitment definition MYTABLE.

-- Change the commitment control option and compile the program again.

Technical description . . . . . . . . : The commitment definition identifier is X'5CC4C6E3C1C3E3C7D9D7'. The job that initiated the change(s) is 954538/QUSER/QZDASOINIT. The logical unit of work identifier is *N. The lock space identifier is *N. The XID is X'5CD5404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040404040'.

Problem is, 954538/QUSER/QZDASOINIT is not an active job. It doesn't show up under active jobs and running this:

 WRKCMTDFN 954538/QUSER/QZDASOINIT

Gives this:

Job 954538/QUSER/QZDASOINIT not found.

...What is happening? How can a job that was finished be connected to pending changes? How can I rollback those changes?

EDIT: Responding to questions in an Answer:

Where are you seeing the message?

That specific one is when, in System iNavigator, I right-click MYTABLE and select Journaling. The original error that made me find the problem is when C# throws:

iDB2SQLErrorException: SQL0910 Object MYTABLE in MYLIB type *FILE has a pending change.

Likewise, I get a "changes are pending" error when trying to remove a referential constraint from MYTABLE.

Do you have *JOBCTL authority? It may be that the job isn't gone, you just don't have authority to see it.

I don't know, nor do I know how to check. If I run:

WRKCMTDFN QUSER/QZDASOINIT

Then a bunch of jobs show up, but 954538 is not one of them.

0

Where are you seeing the message? With the job gone, I wouldn't expect to see that message in an active job. Do you have *JOBCTL authority? It may be that the job isn't gone, you just don't have authority to see it.

0

Okay...

Still no idea what caused this or what was happening. But I managed to fix it. After waiting a day, I was able to delete MYFILE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.